Elementor Problems with last Update

After updating to the latest Elementor Version there occurs a few problems. I want to try to solve here some common issues.

Issue 1: Editor Panel empty

In some languages, the Elementor editor panel on the left remains blank when, for example, you want to edit images, open the style tabs or the settings of the page or post.

It appears to be a language and translation specific problem.

Solutions:

  1. Update to v3.2.2
  2. The fastest solution is, to switch the WordPress Site Language to “English (United States)”.
    Go to: Admin Dashboard > Settings > General > Site Language
  3. Rollback to Elementor v3.1.4
    Go to: Admin Dashboard  > Elementor > Tools > Version Control

Issue 2: Responsive Mode

Some user are reporting to not be able to enter the responsive mode. First of all: it changed a lot. The place where to click to switch to the mobile or tablet view stays but the toggle symbol is modified a bit: from to . When you click the the editor changes immediately to the mobile size of 320 x 667px. Previously you could choose on your own. If you want to see the tablet dimensions, you have to click on the new bar above the page preview:

A few user experience a very small mobile preview window (like 300×150) after clicking on the Responsive Mode Icon with no more ability to change on the buttons at the top.

Solutions:

  1. Update to v3.2.2
  2. Try to refresh all edior related browser files with Ctrl + F5 (or Safari: Cmd + Shift + R)
  3. Rollback to Elementor v3.1.4
    Go to: Admin Dashboard  > Elementor > Tools > Version Control

Issue 3: Slider & Carousel doesn't work anymore

When you use more than one of the following widget on one page, they don’t work:

  • Image Carousel
  • Media Carousel
  • Reviews
  • Slides
  • Testimonial Carousel

In this case a JavaScript error occurs. All the blocks mentioned are using the swiper.min.js and somehow it’s not possible to create more than one. This is the error in the Console of the browser Inspector:

				
					Uncaught (in promise) TypeError: Cannot read property 'prototype' of undefined
at SwiperBC.createSwiperInstance (frontend.min.js?ver=3.2.1:2)
at frontend.min.js?ver=3.2.1:2
				
			

Solutions:

  1. Update to v3.2.2
  2. Deactivate “Improved Asset Loading” in Elementor > Settings > Experiments
  3. Downgrade to previous Elementor Version v3.1.4 

Leave a Reply

Your email address will not be published. Required fields are marked *